Bug dans catégories

Soutien général pour les problèmes techniques avec OpenCart

Bug dans catégories

Messagepar vincentduke » 17 Jan 2016, 20:38

Bonjour !

Voilà nous étions entrain de modifier le texte dans une categorie et en cliquant sur sauvergarder.. un enorme message d'erreur..

Depuis la categorie a disparu du back office et nous ne pouvons plus en recréer sous notre theme journal qui ne semble plus "communiquer" avec open cart aucune idée..

Lorque nous voulons remodifier les categories sous le theme journal nous avons ce message d'erreur :

cannot acces index.php?route=module/journal2/rest/settings/set&key=mega_menu&store_id=0&token=f2449aa7123dd57aa917ec104cddef3f

Une idée ?

Merci beaucop
Opencart : 1.5.5.1
VQmod :
Ebergeur : LWS
site web : http://www.aoeyewear.fr
vincentduke
 
Messages: 23
Inscrit le: 22 Fév 2015, 15:34

Re: Bug dans catégories

Messagepar lucho69 » 19 Jan 2016, 15:50

jamais eu ce type d'erreur
tu avais une sauvegarde au 16 du code ? si qq chose a été écrasé
ou dans la base de données mais là c'est plus difficile en eCommerce , tu as surement des commandes et clients depuis le 17
Opencart 1.5.x - 2.x.x Opencart Assistance Dépannage

Image
lucho69
 
Messages: 907
Inscrit le: 09 Juil 2010, 13:51
Localisation: lyon

Re: Bug dans catégories

Messagepar vincentduke » 19 Jan 2016, 16:03

Nous avons une sauvegarde en date du 13 mais pas moyen de la réinjecter elle fait plus de 4 Mo et open cart prend maxi 2048..

J'attendais une réponse de votre part car tout fonctionne si ce n'est qu on ne peut plus modifier nos "menu item" dans le "main menu" du module "journal"..

Dans tout les cas il faut que çà refonctionne on doit justement refaire des catégories etc..

Tu penses qu'en réinjectant la sauvegarde on a une chance ?

Si oui comment la faire passer donc puisque celle ci est trop volumineuse ?

Merci de ton aide ;)

Cordialement,

Vincent
Opencart : 1.5.5.1
VQmod :
Ebergeur : LWS
site web : http://www.aoeyewear.fr
vincentduke
 
Messages: 23
Inscrit le: 22 Fév 2015, 15:34

Re: Bug dans catégories

Messagepar lucho69 » 19 Jan 2016, 17:00

avant de penser à restaurer, il y a forcément qq chose qui a été cassé , une coupure malencontreuse au moment de l'enregistrement
je pense plus à la base, mais il peut il y avoir aussi les fichiers cache :
- vide bien le cache de Vqmod en admin
- vide aussi le répertoire /system/cache en ne laissant que index.html
après seulement, si tu n'as pas résolu le pb, tu pourrais restaurer la base

la limite 2048 n'est pas Opencart mais vient de ton hébergeur et de phpmyadmin
nous mêmes nous limitons à 1 mega pour les sites de prod (en fait ça empêche les restau)
mon serveur de développement, j'ai limité à 8 mega

en compressant le fichier sauvegarde en Zip , tu es en dessus de 2mega ?

mais attention tu ne peux restaurer QUE si aucune commande et nouveau client depuis le bug, sinon tu casses encore plus en effaçant des commandes
Opencart 1.5.x - 2.x.x Opencart Assistance Dépannage

Image
lucho69
 
Messages: 907
Inscrit le: 09 Juil 2010, 13:51
Localisation: lyon

Re: Bug dans catégories

Messagepar lucho69 » 19 Jan 2016, 17:02

cannot acces index.php?route=module/journal2/rest/settings/set&key=mega_menu&store_id=0&token=f2449aa7123dd57aa917ec104cddef3f

essaie :
cannot acces index.php?route=module/journal2/rest/settings/set&key=mega_menu&store_id=0

essaie aussi avant de restaurer de passer en modif les paramétrages de megamenu de Journal
tu as peut etre tout simplement modifié une categorie qui servait dans le menu
Opencart 1.5.x - 2.x.x Opencart Assistance Dépannage

Image
lucho69
 
Messages: 907
Inscrit le: 09 Juil 2010, 13:51
Localisation: lyon

Re: Bug dans catégories

Messagepar vincentAO » 19 Jan 2016, 17:19

Merci Lucho. Donc c'est bien moi mais j'ai du recréer un nouveau compte utilisateur de forum car en changeant de mail je n'ai toujours pas le mail de confirmation.. anyway :

Alors pour te répondre dans l'ordre :

Vider le cache de VQmod ?tu parles de çà :

Image

Vider le repertoire system/cache ? dans les racine du site via ftp ? si oui quel est son chemin stp ?

Sinon en compactant en zip oui çà fonctionne il est descendu de 4 Mo à 371 ko

Tu me dis d'essayer je cite :

"essaie :
cannot acces index.php?route=module/journal2/rest/settings/set&key=mega_menu&store_id=0"

Je l'essai ou et comment ?

Merci de ta patience et de ton aide j'espere braiment y arriver...
vincentAO
 
Messages: 8
Inscrit le: 19 Jan 2016, 16:20

Re: Bug dans catégories

Messagepar lucho69 » 19 Jan 2016, 18:01

1) Vider le cache de VQmod ?tu parles de çà ? Oui
2) vider le repertoire system/cache ? dans les racine du site via ftp ? si oui quel est son chemin stp ? Ftp , root system/cache/
3) essaie : cannot acces index.php?route=module/journal2/rest/settings/set&key=mega_menu&store_id=0"
Je l'essai ou et comment ? : j'ai essayé de copier l'url après ton adresse de site, mais ca existe pas

passe par l'admin du module mega_menu de Journal, on dirait que le pb vient de là
Opencart 1.5.x - 2.x.x Opencart Assistance Dépannage

Image
lucho69
 
Messages: 907
Inscrit le: 09 Juil 2010, 13:51
Localisation: lyon

Re: Bug dans catégories

Messagepar vincentAO » 19 Jan 2016, 19:02

J'utilise journal V 2.6.7 il n' y a pas d'admin dans le module journal ? ou alors je ne le trouve pas :/
vincentAO
 
Messages: 8
Inscrit le: 19 Jan 2016, 16:20

Re: Bug dans catégories

Messagepar vincentAO » 19 Jan 2016, 19:05

En effacnat tout les catégories on a parfois plus ce messgae..

Puis en en recreant parfois çà revient de maniere aléatoire..

Ce nouveau message vient d'apparaitre :

Notice: Error: Could not load language module/journal2.old! in /var/www/clients/client1/web11/web/vqmod/vqcache/vq2-system_library_language.php on line 39
vincentAO
 
Messages: 8
Inscrit le: 19 Jan 2016, 16:20

Re: Bug dans catégories

Messagepar vincentAO » 19 Jan 2016, 19:09

JE tiens une piste dans catégori Lucho :

J'ai environ 10 categories que j'ai créé...

Pourtant il me met "voir 1à20 de 43" et on a " pages de categories avec 2 pages vide..

Commes si il y avait 30 catégories "fantômes" invisibles ??
vincentAO
 
Messages: 8
Inscrit le: 19 Jan 2016, 16:20

Re: Bug dans catégories

Messagepar lucho69 » 19 Jan 2016, 19:19

si tu as un message language module/journal2.old , c'est que tu as un soucis , peut etre lié à une mise à jour de journal
c'est comme ci une ancienne version etait encore active
tu as fait une maj de journal ?
Opencart 1.5.x - 2.x.x Opencart Assistance Dépannage

Image
lucho69
 
Messages: 907
Inscrit le: 09 Juil 2010, 13:51
Localisation: lyon

Re: Bug dans catégories

Messagepar vincentAO » 19 Jan 2016, 19:26

Nan j'ai pas fait de maj de journal...

Toute ces catégories fantomes plus cette erreur la je suis perdu :/
vincentAO
 
Messages: 8
Inscrit le: 19 Jan 2016, 16:20

Re: Bug dans catégories

Messagepar vincentAO » 19 Jan 2016, 19:32

Bon je met a jour vers la 2.6.9... on verra bien au point ou on en est.... :/
vincentAO
 
Messages: 8
Inscrit le: 19 Jan 2016, 16:20

Re: Bug dans catégories

Messagepar vincentAO » 19 Jan 2016, 19:49

MAJ 2.6.9 effectué on a toujours ce problème de sauvegarde de nos catégories dans journal.... :/

il y a du challenge là...
vincentAO
 
Messages: 8
Inscrit le: 19 Jan 2016, 16:20

Re: Bug dans catégories

Messagepar vincentAO » 19 Jan 2016, 21:56

L'ajout d'image dans le code Html d'une des pages a créé un bug entre jounrnal et open cart..

La capacité d'octet par page a été dépassé du a un copié / collé.. nous aurions du ajouté les image depuis le serveur.. c'est une erreur.. mais c'est fragile est pas stable puisque hors "module journal" nous n'avons pas le problème..

Nous allons re-détruire le site ( seconde fois en 8 semaine et tout reconstuire.

Merci à Lucho pour ses conseils quoi qu'il en soit ;)

Mais chez nous on avance on ne recule pas !! whooo haa !
vincentAO
 
Messages: 8
Inscrit le: 19 Jan 2016, 16:20


Retour vers Soutien Général

Qui est en ligne ?

Utilisateur(s) parcourant actuellement ce forum : Bing [Bot] et 2 invité(s)

cron
Copyright © 2009-2013 OpenCart France - Tous droits réservés