Identifiant admin perdu

Soutien général pour les problèmes techniques avec OpenCart

Identifiant admin perdu

Messagepar JacquesD » 24 Mai 2013, 21:13

slt, merci d'avance pour l'aide qu'il me sera porter.

tout est dans le titre, j'ai perdu l'identifiant pour me connecter à l'admin d'Opencart. Lorsque je fais passe perdu il ne me peux que de changer de passe sans me donner ID, je suis donc coincer.

J'ai tenté de voir sur la base de donnée si je pouvais avoir ID on allant USER mais sa ne fonctionne pas avec ce login.

donc je vais appelle a vous pour m'indiquer la démarche a suivre dans ce type de situation.
Dernière édition par JacquesD le 01 Juin 2013, 12:11, édité 1 fois au total.
Quand je serai grand, je serai concepteur de site :p

héber : OVH
Opencart: 1.5.3.1
JacquesD
 
Messages: 3
Inscrit le: 24 Mai 2013, 20:38
Localisation: Cergy

Re: Identifiant perdu

Messagepar nabouill » 28 Mai 2013, 09:20

Bonjour,
Connectez vous sur le phpmyadmin pour modifier la base mysql, accedez à la table"(préfixe_)user"
copiez l'utilisateur existant (plutôt que de l'éditer au cas où ça ne marcherais pas)
puis vous éditez l'utilisateur de vous venez de créer par la copie en mettant:

-username: admin
-password: 5d64cc45fee444dfcabb8bca91cc44b59d55014e
-salt: 9cabc0f8e

Ce qui selon les tests que j'ai moi même réalisé sur ma base, créer un utilisateur "admin" avec le mot de passe "admin"

En ésperant que cela fonctionne. même si je ne vous promet rien

edit: il va sans dire qu'une sauvegarde de la base est impératif avant toutes modifications manuel de celle-ci
-OpenCart v1.5.4 en Français
-Hébergeur: 1and1
-Template + ou - perso
-Module: vqmod manager, page content.
-Script vqmod:
    -beop_all_clean_urls.xml
    -cache_manager.xml
    -remove_category_image.xml
    -vqmm_menu_shortcut.xml
nabouill
 
Messages: 36
Inscrit le: 11 Jan 2012, 02:15

Re: Identifiant perdu

Messagepar JacquesD » 01 Juin 2013, 12:10

slt, merci d'avoir pris le temps de me répondre et désoler d'avoir mis du temps et voir ce qui m'a été répondu.

effectivement ça à fonctionner, merci de l'aide.

à peine le temps de fêter cette p'tite victoire, que l'id ma reposé problème. je suis retourné voir dans la base de donnée pour y voir (préfixe_)user que l'id avait encore été modifié par un tiers! là il m'a juste suffi de le recopier pour me reconnecté comme le passe lui n'a pas été changé.

merci de l'aide.
Quand je serai grand, je serai concepteur de site :p

héber : OVH
Opencart: 1.5.3.1
JacquesD
 
Messages: 3
Inscrit le: 24 Mai 2013, 20:38
Localisation: Cergy


Retour vers Soutien Général

Qui est en ligne ?

Utilisateur(s) parcourant actuellement ce forum : Aucun utilisateur inscrit et 2 invité(s)

cron
Copyright © 2009-2013 OpenCart France - Tous droits réservés