Problème dans les mails

Soutien général pour les problèmes techniques avec OpenCart

Problème dans les mails

Messagepar animalife » 12 Fév 2016, 15:43

Bonjour,

Je suis toute nouvelle sur le forum.
Je vais surement oublié des informations, mais je suis plutôt novice en matière d'informatique, je m'excuse d'avance.

J'ai configuré ma boutique sur Opencart que j'ai téléchargé à partir de mon hébergeur (hebergeur discount). Je gère donc la boutique sur mon navigateur web.

Tout va à peu près bien excepté pour les commandes :

- Je ne reçois pas de mail quand j'ai une nouvelle commande ou un nouveau compte de client alors que j'ai bien coché "oui" au deux dans Système->Paramètres

- Les mails que reçoivent les client sont bourrés de caractères bizarres exemple : Votre commande a été mise à jour comme suit. Comme s'il ne reconnaissait aucun accent ou autre caractère spéciaux.

- Dans le mail de confirmation de commande, les liens renvoyant à l'historique de commande ne sont pas valable (idem quand on tente d'accéder à l'historique depuis son compte sur le site).

Pouvez vous m'aider ?

Merci d'avance et Bonne journée à tous
animalife
 
Messages: 1
Inscrit le: 12 Fév 2016, 13:35

Re: Problème dans les mails

Messagepar lucho69 » 22 Fév 2016, 12:12

tu dois avoir un accès FTP, car il faut aller modifier les fichiers config ou index ...
dans index.php : $response->addHeader('Content-Type: text/html; charset=utf-8'); (pour les pb d'accents)
pour les mails, ne pas utiliser dans le paramétrage la fonction mail() mais smtp avec un compte mot de passe réel
les spammeurs utilisent mail() aussi beaucoup d'opérateurs mails refusent des maisl non signés, il te faut donc utiliser SMTP et choisir un compte et serveur SMTP de ton domaine, mas des comptes type Gmail ou autres

enfin pour les mails, certains mails textes comme les confirmations d'inscription, les fichiers traduction en FR sont incorrects, je te conseille de les revoir sans accents ou essayer au contraire un accent en clair et pas é ou autre

les modifs de fichiers langue doivent se faire avec une sauvegarde FTP avant car une erreur entraine un écran blan ou erreur 500
Opencart 1.5.x - 2.x.x Opencart Assistance Dépannage

Image
lucho69
 
Messages: 907
Inscrit le: 09 Juil 2010, 13:51
Localisation: lyon


Retour vers Soutien Général

Qui est en ligne ?

Utilisateur(s) parcourant actuellement ce forum : Bing [Bot] et 2 invité(s)

cron
Copyright © 2009-2013 OpenCart France - Tous droits réservés